Module is.codion.swing.framework.ui
Package is.codion.swing.framework.ui
Class EntityApplicationPanel.ControlKeys
java.lang.Object
is.codion.swing.framework.ui.EntityApplicationPanel.ControlKeys
- Enclosing class:
EntityApplicationPanel<M extends SwingEntityApplicationModel>
The controls of the main menu, the menus included, available via
EntityApplicationPanel.control(ControlKey) and laid out via
EntityApplicationPanel.configureMainMenu(Consumer).
The menus with a default layout, FILE_MENU, VIEW_MENU, TOOLS_MENU and HELP_MENU,
can be configured via Controls.Layout.controls(ControlsKey, Consumer), the others, created from what the
application has, LOOKUP_MENU and LOG_CONTROLS, only placed or left out.
-
Field Summary
FieldsModifier and TypeFieldDescriptionstatic final ControlKey<CommandControl> Displays information about the application.static final ControlKey<ToggleControl> Toggles whether the application window is always on top.static final ControlKey<CommandControl> Exits the application.static final Controls.ControlsKeyThe File menu.static final ControlKey<CommandControl> Displays the help.static final Controls.ControlsKeyThe Help menu.static final ControlKey<CommandControl> Displays the keyboard shortcuts.static final ControlKey<Controls> The log controls: the log level, opening the log file or folder, and the SQL tracing, those available.static final ControlKey<Controls> The Lookup menu, a control for each lookup panel, not available without lookup panels.static final ControlKey<CommandControl> Displays a dialog for selecting the look and feel.static final ControlKey<CommandControl> Displays a dialog for selecting the scaling.static final Controls.ControlsKeyThe Tools menu, empty by default, and so left out.static final Controls.ControlsKeyThe View menu. -
Method Summary
-
Field Details
-
EXIT
Exits the application. -
SELECT_LOOK_AND_FEEL
Displays a dialog for selecting the look and feel.- See Also:
-
SELECT_SCALING
Displays a dialog for selecting the scaling. -
ALWAYS_ON_TOP
Toggles whether the application window is always on top. -
HELP
Displays the help.- See Also:
-
KEYBOARD_SHORTCUTS
Displays the keyboard shortcuts. -
LOG_CONTROLS
The log controls: the log level, opening the log file or folder, and the SQL tracing, those available.- See Also:
-
ABOUT
Displays information about the application. -
FILE_MENU
The File menu.Default layout:
EXIT -
VIEW_MENU
The View menu.Default layout:
SELECT_LOOK_AND_FEEL,SELECT_SCALING, separator,ALWAYS_ON_TOP -
TOOLS_MENU
The Tools menu, empty by default, and so left out. -
LOOKUP_MENU
The Lookup menu, a control for each lookup panel, not available without lookup panels. -
HELP_MENU
The Help menu.Default layout:
HELP,KEYBOARD_SHORTCUTS, separator,LOG_CONTROLS, separator,ABOUT
-